BolPoint.wordpress.com

March 29, 2013

Menghapus berbasis modifikasi file Comand Linux / Unix “delete files based on modified date”

Filed under: Linux — bolpoint @ 11:23 pm

Bagaimana cara kita menghapus file di cache yang telah berumur lebih dari satu bulan
untuk operational dasar kita menggunakan perintah

#rm

tapi karena kita mau men sort file yang telah berumur lebih dari 30 hari maka kita perlu memodifikasi perintah find

find $DIR -ctime +30 -exec rm {} \;

dapat juga menggunakan -mtime. -ctime akan memberikan perubahan waktu inode terakhir, yang mungkin lebih dari terakhir kali file tersebut diubah.

Advertisements

January 4, 2013

Kapasitas used space avaliable Hardisk command Linuc

Filed under: Linux — bolpoint @ 7:04 am

Masuk ke root
#sudo su

#df -l
maka akan tampak

Kapasitas Hardisk

November 26, 2012

Monitoring Trafic dengan Command Line Linux Pada Interface Jaringan pada tiap Host

Filed under: Linux — bolpoint @ 4:48 am

IFTOP
iftop perintah Memantau trafic jaringan pada antarmuka jaringan, atau pada interface pertama di temukan yang tampak seperti sebuah antarmuka eksternal jika tidak di tentukan, dan menampilkan tabel penggunaan bandwidth saat oleh pasangan host.
iftop adalah alat yang sempurna untuk server Linux jarak jauh melalui sesi ssh.

iftop harus dijalankan oleh root atau user yang memiliki hak akses yang cukup untuk memonitor semua trafic jaringan pada antarmuka jaringan.

Ketik perintah iftop di tge shell prompt untuk memantau trafic:

#iftop

Terlihat di Gambar di bawah

Iftop

Namun, iftop bekerja paling baik bila Anda menggunakan filter. Misalnya, jika Anda ingin mengetahui berapa banyak pengguna bandwidth yang membuang-buang atau mencoba untuk mencari tahu mengapa jaringan lambat,

# iftop -f icmp

Anda dapat menampilkan atau analisis paket yang mengalir masuk dan keluar dari jaringan 192.168.1.0/24:

# iftop -F 192.168.1.0/24

Nonaktifkan output untuk lalu lintas DNS dengan menggunakan kode saringan seperti:

# iftop -f 'not port domain'

iftop memiliki banyak pilihan membaca halaman manual untuk informasi lebih lanjut.

IPTRAF

Setelah diinstal, melaksanakan IPTraf dari baris perintah akan meluncurkan sistem menu ascii berbasis yang akan memungkinkan Anda untuk melihat jumlah lalu lintas IP, statistik antarmuka rinci, dan kerusakan per protokol antarmuka fisik
untuk menginstall
#apt-get install iptraf

Untuk menjalankan tinggal ketik

#iptraf

IPTRAF
Lihat juga:
Keeping a log of daily network traffic for ADSL or dedicated remote Linux box

September 28, 2012

PCQ Di Mikrotik- Bandwith Manager

Filed under: Linux — bolpoint @ 1:13 pm

3. Kita buat pengaturan firewall mark.

/ip firewall mangle add chain=forward src-address=192.168.0.0/28 action=mark-connection new-connection-mark=NET1-CM

 

Hasilnya…

/ip firewall mangle add connection-mark=NET1-CM action=mark-packet new-packet-mark=NET1-PM chain=forward

Hasilnya…

4. Membuat queue types “dengan nama pcq_downstream”

/queue type add name=PCQ_download kind=pcq pcq-classifier=dst-address

5. Membuat queue types “dengan nama pcq_upstream”

/queue type add name=PCQ_upload kind=pcq pcq-classifier=src-address

6. Membuat queue tree interface “lan”

/queue tree add parent=lan queue=PCQ_download  packet-mark=NET1-PM

7. Membuat queue tree interface “public”

/queue tree add parent=public queue=PCQ_upload packet-mark=NET1-PM

8 Selesai. selamat mencoba. (google)

NB: CM(Connection-Mark), PM(Packet-Mark)

May 4, 2012

Setup – Install Proftpd Ubuntu dengan mudah.

Filed under: Linux — bolpoint @ 3:04 am

Buka terminal
=====#####======
$sudo su
$pass:
#apt-get install proftpd

=====#####======

tunggu sampai proses selesai

Konfigurasi Firewall untuk dapat listen di port 21 (default)

untuk konfigurasi Proftpd adalah sebagai berikut :
=====#####======

Include /etc/proftpd/modules.conf
UseIPv6 off
ServerName “bolpoint.wordpress.com”
ServerType standalone
DeferWelcome off
MultilineRFC2228 on
DefaultServer on
ShowSymlinks on
TimeoutNoTransfer 600
TimeoutStalled 600
TimeoutIdle 1200
DisplayLogin welcome.msg
DisplayFirstChdir .message
ListOptions “-l”
DenyFilter \*.*/
DefaultRoot ~
Port 21
MaxInstances 30
User proftpd
Group nogroup
Umask 022 022
AllowOverwrite on
TransferLog /var/log/proftpd/xferlog
SystemLog /var/log/proftpd/proftpd.log

TLSEngine off

QuotaEngine on

Ratios on

DelayEngine on

ControlsEngine on
ControlsMaxClients 2
ControlsLog /var/log/proftpd/controls.log
ControlsInterval 5
ControlsSocket /var/run/proftpd/proftpd.sock

AdminControlsEngine on

AllowUser kasir
DenyALL

Umask 022 022
AllowOverwrite off

DenyAll

Umask 022 022
AllowOverwrite off

DenyAll

Umask 022 022
AllowOverwrite on

DenyAll

AllowAll

UseReverseDNS off

=====#####======

restart dan uji coba dalam localhot

=====#####======
# /etc/init.d/proftpd restart
# ftp localhost

=====#####======
jika login sukses
selamat anda telah menginstall server FTP ..

lakukan koneksi dengan uji coba dari komputer klient. jika error saat melakukan koneksi dengan filezilla silahkan baca postingan saya yang lain https://bolpoint.wordpress.com/2012/05/04/command-list-error-connection-timed-out-error-failed-to-retrieve-directory-listing-on-ubuntu-with-proftpd/

“Jazakumullah khairan katsiran. Wa jazakumullah ahsanal jaza“

Command: LIST Error: Connection timed out Error: Failed to retrieve directory listing On Ubuntu with Proftpd

Filed under: Linux — bolpoint @ 1:24 am

Setelah sukses menginstal Proftpd dengan di uji di localhost dan koneksi lewat Command Prompt komputer klient.
Tapi waktu dilakukan koneksi dengan Fezilla terdapat error waktu koneksi dilakukan sebagai berikut:

###———###
Command: LIST
Error: Connection timed out
Error: Failed to retrieve directory listing
###———###
akhirnya setelah googling solusinya adalah dengan mengubah pengeturan di Filezilla
Transfers Setting –> Transfer Mode
dari “Default” di rubah menjadi “Active”

Beres deh….

“Jazakumullah khairan katsiran. Wa jazakumullah ahsanal jaza“

February 10, 2012

Bandwidth Management ClearOS

Filed under: Linux — bolpoint @ 5:35 pm

Setting dulu BM di COS melalui webconfig di
Gateway –> Bandwidth and QoS –> Bandwidth
Sebelumnya isi Downstream dan Upstream yang kita dapat dari ISP disini saya isi 1024 untuk download dan 256 untuk upload

Selanjutnya masuk ke menu Add Advanced Rule
Disini ada beberapa kolom yang harus kita isi
1. Nickname : silahkan isi sesuai keinginan kita
2. IP Address / IP Address Range : ada 2 pilihan
– Destination artinya IP tujuan/ke IP mana bandwidth itu masuk (IP di jaringan LAN)
– Source artinya IP sumber/dari IP mana bandwith itu masuk (IP public dari tiap2 domain).
3. Port : ada 2 pilihan juga
– Destination artinya port tujuan/ke port berapa bandwith itu masuk (untuk lihat port destiation bisa melalui Reports –> Network –> Network Traffic pilih eth1)
– SOurce artinya port sumber/dari port berapa bandwith itu masuk (misal http=80, https=443 dll)

4. Direction : ada 2 pilihan juga
– Download dan upload
Jika kita isi download maka di kolom port kita pilih source.
Jika kita isi upload maka di kolom port kita pilih destination.
5. Rate : rata2 pemakaian bandwidth
6. Ceiling : batas atas (maksimum pemakaian bandwidth)
7. Greed : prioritas untuk tiap2 rule yang kita buat.

Selanjutnya mari kita mulai isi satu persatu untuk masing2 port

1. Untuk browsing di port 80
Kita tahu bahwa jika proxy diset dengan transparent on maka untuk port 80 tidak bisa di bagi per IP. Akhirnya dari hasil try and error dapat diantisipasi dengan mengosongkan kolom IP Address / IP Address Range (khusus port 80 saja)
jadi lebih detailnya kita isi sebagai berikut :

Nickname : browser_down (sesuaikan)
IP Address / IP Address Range : kosongkan
Port : 80
Direction : Download
Rate : 64
Ceiling : 512
greed : low

Oke sebelum kita lanjut saya akan jelaskan dulu rule tersebut.
Dari rule ini terlihat bahwa bandwith kita bagi 2 yaitu 512Kb untuk port 80 dan sisanya 512Kb untuk port lainnya. Jika Bw kita lebih besar misalnya 2Mb akan lebih efektif lagi jadi bisa kita isi ceilingnya 1024 artinya 1Mb untuk port 80 dan 1Mb lagi untuk port yang lain.
Karena IP address kita kosongkan maka dari 512Kb tersebut dialokasikan untuk semua client, artinya jika hanya 1 client yang browsing maka client tersebut dapet full bandwidth 512Kb tapi jika semuanya browsing maka akan dibagi sesuai kebijakan rule tersebut.

2. Untuk membatasi upload dari tiap client
Nickname : browser_up (sesuaikan)
IP Address / IP Address Range : kosongkan
Port : [Destination] 80
Direction : Upload
Rate : 64
Ceiling : 128
greed : medium

Sebenarnya dengan 2 rule ini sudah cukup untuk menjalankan game online dan browsing secara bersamaan silahkan dicoba dulu sebelum ditambah dengan rule yang lainnya.
Dari hasil uji coba dengan pemakaian kedua rule tersebut terlihat bahwa untuk browsing akan terasa lambat jika ada client yang download atau streaming youtube tapi tidak mempengaruhi client yang bermain game karena beda port kecuali jika ada game online yang berjalan di port 80, kok jadi kebalik yach? yang ngelag malah browsingnya hehehehe, Disinilah pentingnya kita terapkan delay pool parameter (sudah dibahas di forum ini coba searching yach)

Tapi sedikit sharing, Squid yang saya gunakan seperti berikut :

acl to_localhost dst 127.0.0.0/8
acl server 192.168.100.1
acl admin 192.168.100.10
acl client src 192.168.100.0/24
acl ekstensiblok url_regex -i \.swf \.wmv \.msi \.mpg \.mpeg \.wma \.wav \.3gp \.3gpp \.avi \.dat \.flv \.mkv \.mp4 \.mp3 \.mov \.rar \.zip \.7z \.iso \.pdf \.ace \.exe \.torrent \.aac \.ogg \.rm \.asf
acl streamregex url_regex -i watch\? get_video\?video_id videodownload\? videoplayback\? videoplay\? dailymotion video\.[a-z]\.fbcdn\.net

# delay_initial_bucket_level 50
delay_pools 3

delay_class 1 1
delay_parameters 1 -1/-1
delay_access 1 allow server
delay_access 1 allow admin
delay_access 1 deny all

delay_class 2 1
delay_parameters 2 24000/1024000
delay_access 2 allow streamregex client
delay_access 2 deny all

delay_class 3 1
delay_parameters 3 24000/512000
delay_access 3 allow ekstensiblok client
delay_access 3 deny all

Oke sampai disini dulu nantikan kelanjutan rule yang lainnya.
berikut screenshot bandwith monitor dan network traffic dengan mengaktifkan 2 rule diatas an disandingkan dengan delay pool.

Pemutakhiran Terakhir ( Sabtu, 03 Desember 2011 02:00 )

December 16, 2011

squidclient mgr:info performance squid

Filed under: Linux — bolpoint @ 1:36 am
Tags:

Untuk mengakses cachemgr general runtime information via konsol :

#squidclient mgr:info
atau
#squidclient -p 3128 mgr:info

Melalui browser :

general runtime information

Hasilnya angka-angka + kata-kata banyak sekali 😀

let’s read apa artinya kata-kata dan angka-angka itu, yang penting-penting saja ya 😀

Connection information for squid:
	Number of clients accessing cache:	15
	Number of HTTP requests received:	1775447
	Number of ICP messages received:	0
	Number of ICP messages sent:	0
	Number of queued ICP replies:	0
	Number of HTCP messages received:	0
	Number of HTCP messages sent:	0
	Request failure ratio:	 0.00
	Average HTTP requests per minute since start:	144.9
	Average ICP messages per minute since start:	0.0
	Select loop called: 34743641 times, 21.162 ms avg

Number of clients accessing cache:

Jumlah IP unik yg pernah mengakses squid. Misalnya jaringan dengan 14 PC client, 1 mikrotik, akan dibaca ada 15 client yg mengakses squid. Kalo misalnya ada 1 laptop yg kemudian terhubung ke squid, squid akan membaca ada 16 client. Biarpun kemudian laptop itu udah tidak terhubung lagi ke squid, tetap 16 client yg ditampilkan cachemgr sampe squid reboot

Number of HTTP requests received s/d Average ICP messages per minute since start

dari namanya sudah self explanatory, ga perlu dijelaskan lagi

Select loop called

Kesalahpahaman menjurus ke salah kaprah sering terjadi disini. angka ini bukan petunjuk performa kecepatan squid merespon request dari client yang sebenarnya.

Ini adalah waktu interval antara sebuah fungi select() [atau poll()/epoll()] dipanggil, dan waktu selanjutnya fungsi itu dipanggil lagi, bukan seberapa cepat request client diproses squid.

Semakin sibuk jaringan, nilai Select Loop Called akan semakin kecil

Cache information for squid:
	Request Hit Ratios:	5min: 52.9%, 60min: 42.6%
	Byte Hit Ratios:	5min: 33.2%, 60min: 35.6%
	Request Memory Hit Ratios:	5min: 1.5%, 60min: 1.6%
	Request Disk Hit Ratios:	5min: 94.0%, 60min: 90.2%
	Storage Swap size:	20939596 KB
	Storage Mem size:	8180 KB
	Mean Object Size:	11.03 KB
	Requests given to unlinkd:	0

Request Hit Ratios

Prosentase cache hit dibanding HTTP request

Byte Hit Ratios

Squid akan membandingkan jumlah bytes diterima dari server asli (received) misalnya dari server warneter.net dengan jumlah bytes yang dikirim ke client (sent). Jika received lebih kecil sent, byte hit ratio akan positif. Nilai ini dapat juga menjadi negatif, artinya received lebih besar dari sent jika client sering membatalkan request sebelum semua byte selesai di sent oleh squid

Request Memory Hit Ratios

Prosentase cache hit yang diambil dari memory bukan dari Hard disk. Kalau di cache log, ini adalah persentase TCP_MEM_HIT

 

Request Disk Hit Ratios

Prosentase cahe hit yang diambil dari hard disk. Kalau di cache log, ini adalah persentase TCP_HIT

Yang harus diingat, Request Memory Hit Ratios dan Request Disk Hit Ratios diatas hanya nilai sesaat, bukan nilai pasti cache hit. Besarnya cache hit yang sebenarnya diliat dari cache client list

#squidclient mgr:client_list

Liat di baris-baris paling bawah :

TOTALS
ICP : 0 Queries, 0 Hits (  0%)
HTTP: 1833797 Requests, 791694 Hits ( 43%)

43% itu adalah cache hit yang sebenarnya, berapa % bandwidth internet yang dihemat dengan penggunaan squid cache proxy

Storage Swap Size

Jumlah data yang ter-cache, atau tersimpan di hard disk, dalam satuan kilobytes.

Storage Mem size

Jumlah data yang ter-cache, atau tersimpan di memory atau RAM, dalam satuan kilobytes.

Mean Object Size

Hasil pembagian besarnya storage swap size dengan jumlah file cache. Hasilnya adalah size rata-rata besarnya file cache

Requests given to unlinkd

unlinkd adalah proses external yang digunakan squid untuk menghandle deteltion/penghapusan file cache. Jika nilainya 0 berarti proses unlinkd tidak digunakan dalam konfigurasi squidnya. Saat compile squid, tambahkan option –disable-unlinkd saat ./configure

Median Service Times (seconds)  5 min    60 min:
	HTTP Requests (All):   0.03622  0.07825
	Cache Misses:          0.44968  0.24267
	Cache Hits:            0.00091  0.00091
	Near Hits:             0.76407  0.39928
	Not-Modified Replies:  0.00091  0.00091
	DNS Lookups:           0.00000  0.00000
	ICP Queries:           0.00000  0.00000

Sebelum bahas soal ini, lebih baik pahami dulu mengenai apa itu MEDIAN

HTTP Request (All)

Median time semua http request, dihitung mulai dari saat squid menerima request dari client sampai squid selesai merespon request itu (client menerima data hasil dari request0nya) DNS Lookup time juga dihitung dalam median time http request.

Cache Misses

response time untuk request yg tidak tercache, ato cache miss

Cache Hits

waktu yg dibutuhkan squid untuk mengambil data yang sudah ter-cache di hard disk kepada client. Inilah salah satu point performa squid yang sebenarnya, seberapa cepat squid mengambil cache dari harddisk dan kemudian mengirimnya kepada client. Jika cache hit time terlalu tinggi, berarti mulai terjadi bottle neck. Penyebabnya bisa macam-macam, mulai dari konfig squid yang kurang baik, konfig OS-nya yang kurang baik, maupun karena hardware, utamanya hard disk yang kurang baik. Di access log tercatat sebagai TCP_HIT, TCP_MEM_HIT, and TCP_OFFLINE_HIT

Near Hits

Berhubungan dengan TCP_REFRESH_HIT di access log, squid akan request e server asli apakahada file yang lebih baru dari file di cache. server asli akan merespon, bahwa tidak ada modifikasi atas file yg direquest oleh squid, baru kemudian squid mengirim file cache tersebut ke client

Not-Modified Replies

Jika ada client yang mengirim conditional request dan squid merespon tanpa menghubungi server aslinya. Logged as TCP_IMS_HIT di access log

DNS Lookup

Waktu yang dibutuhkan squid untuk meng-query (menanyakan alamat suatu URL) DNS server

Sumber : warneter

December 11, 2011

Menambah hardisk baru di squid untuk cache_dir

Filed under: Linux — bolpoint @ 5:58 am

1. pasang hardiks di mesin komputer

2. #apt-get install gparted

berfungsi untuk menginstall partition editor di mesin linux

3. buat partiton beru di linux pilih format reiserfs besar partisi 6 Gb karena alokasi untuk cache_dir 4 Gb

4. tambahkan dir di cache squid

#mkdir /var/spool/squid-1

#chown -R proxy.proxy /var/spool/squid-1

5. tambahkan baris di /etc/fstab

/dev/sdb1 /var/spool/squid-1 reiserfs defaults 0 0

#berfungsi untuk mounting otomatis

6. tambahkan baris baru di squid.conf

cache_dir aufs /var/spool/squid-1 4096 9 256

7. #/etc/init.d/squid stop

#/usr/sbin/squid -z

#/etc/init.d/squid start

NB: untuk melihat UUID dan jenis partisi di Linux gunakan perintah #blkid

December 9, 2011

Membatasi Download Dengan Delay Pool di Proxy

Filed under: Linux — bolpoint @ 12:32 am

konfigurasi

File konfigurasi squid adalah squid.conf
ada beberapa tag konfigurasi untuk delay pools di squid.conf.

  1. delay_pools <jumlah>
    menyatakan berapa banyak bagian/pool yang akan dibuat
    misal delay_pools 2
  2. delay_class <bagian tipe/class>
    menentukan klas/tipe pembagian bandwith dari setiap pool. 1 pool hanya boleh memiliki 1 clas, tidak lebih atau kurang.
    bagian merupakan nomer urut dari jumlah pool didelay pool, jadi ada 1 s/d n bagian dimana n merupakan angka jumlah pada delay_pools
    tipe merupakan tipe class delay yang dipakai.
    Secara umum tipe menyatakan bagaimana cara membagi bandwidth, ada 3 tipe:
tipe/class keterangan
1 semua bandwidth yang ada akan dibagi sama rata untuk semua user squidex ada bandwidth 128 dan semua bandwith dipakai untuk browsing
2 membatasi pemakaian bandwith dari total bandwidth yang ada, dan bandwith yang diperuntukan squid akan dibagi semua user dengan sama rata.ex ada bandwidth 128 dimana 28 kbit dipakai untuk email dan sisanya (128-28) 100 kbit dipakai untuk browsing
3 membatasi pemakaian bandwidth dari total bandwidth yang ada, setiap network class C akan mendapat bandwidth sama besar, setiap user pernetwork akan mendapat bandwidth yang sama besar dari total bandwidth per networkex: bandwidth tersedia 512 kb, untuk browsing disediakan bandwidth 384 kb, sisanya untuk aktifitas lain.
Di jaringan tersebut ada 3 departement dengan network yang berbeda misal lab (192.168.1.0/24), manajer(192.168.2.0/24), sales(192.168.3.0/24).
nah misah oleh admin di set bahwa pernetwork mendapat jatah 128 kb/s.
maka user� di sales akan mendapat pembagian bandwidth sama besar dari total 128 kb/s.
maka user� di lab akan mendapat pembagian bandwidth sama besar dari total 128 kb/s.
maka user� di manajer akan mendapat pembagian bandwidth sama besar dari total 128 kb/s.

misal:

delay_class 1 2    # pool 1 memakai clas tipe 2
delay_class 2 3    # pool 2 memakai clas tipe 3
  • delay_access <bagian acl>
    Memberi batasan siapa saja yang boleh mempergunakan delay pools ini.
    Penting untuk diingat sebaiknya setelah menetukan batasan jangan lupa di akhiri dengan deny all.
    misal:

    delay_access 1 allow manajer
    delay_access 1 deny all
    delay_access 2 allow sales
    delay_access 2 deny all
  • delay_parameters
    Ini adalah bagian terpenting dari delay pools memberikan aturan main setiap delay pools yang dibentuk.
    delay parameter mempunyai format yang disesuaikan dengan tipe/class yang dipakai.
    Tapi disetiap tipe yang dipakai ada 1 format baku yaitu restore/max.restore menunjukkan maksimum kecepatan data yang dapat dilewatkan bila harga max sudah terlampaui, dalam satuan bytes/secondmax menunjukkan besar-nya file atau bucket yang dapat dilewatkan tanpa melalui proses delay. dalam satuan bytes.

    Yang perlu diperhatikan dari satuan diatas adalah harga restore dimana kita sering menerima/menyewa/membeli bandwidth dari provider dalam satuan bits/second bukan bytes/second. Sedangkan satuan kecepatan yang ditunjukkan oleh Microsoft pada saat mendonlot file adalah bytes/sec.
    Sedangkan satuan dari harga max sudah sesuai dengan kebiasaan sehari-hari, dimana kita memberi besaran bytes pada file-file.
    1 byte = 8 bit.

    SpesialCase: -1/-1 berarti unlimited atau tidak dibatasi pada nilai restore/max

    ex: 1000/64000 harga restore sama dengan 8000 bits/sec atau 8 kbits/sec.
    Yang artinya user akan mendapat donlot brustable selama file yang akan dibuka lebih kecil dari 64 kbytes, jadi kecepatan bisa diatas 8 kbit/sec.
    Bila ternyata file yang dibuka melebihi 64 bytes, maka proses limitasi akan segera dimulai dengan membatasi kecepatan maksimal 8 kbits/s.

    class 1
    delay_parameters <#pool individual>
    ex: delay_parameters 1 1000/64000
    Berarti semua network akan mendapat bandwidth yang sama di pool no 1.
    Sebesar 1 kbytes/sec (8 kbits/sec), dengan burstable file 64 kb.
    class 2
    delay_parameters <#pool agregate individual>
    ex: delay_parameters 1 32000/32000 1000/64000
    Berarti squid akan memakai bandwidth maksimum (32000*8) 256kbits dari semua bandwidth.
    Bila terdapat lebih dari 1 network class C, maka total yang dihabiskan tetap 256 kbit/sec
    dan tiap user akan mendapat bandwidth maksimum 1 kbytes/sec (8 kbits/sec), dengan burstable file 64 kb.
    class 3
    delay_parameters <#pool agregate network individual>
    ex: delay_parameters 1 32000/32000 8000/8000 1000/64000
    Berarti squid akan memakai bandwidth maksimum (32000*8) 256kbits dari semua bandwidth.
    Bila terdapat lebih dari 1 network class C, maka setiap network akan dipaksa maksimum sebesar (8000*8) 64 kbits/sec
    dan tiap user pada satu network akan mendapat bandwidth maksimum 1 kbytes/sec (8 kbits/sec), dengan burstable file 64 kb.

Contoh 1

dalam 1 network dengan penggunaan bandwidth total tidak dibatasi terdapat beberapa komputer dengan klasifikasi sebagai berikut

  • admin, server dengan bandwidth unlimited
  • staff dengan bandwidth 1,5 kbytes/sec, bila file yang diakses melebihi 64Kbte
  • umum dengan bandwidth 1 kbytes/sec, bila file yang diakses melebihi 32 Kbyte
acl all src 0.0.0.0/0.0.0.0
acl admin src 192.168.1.250/255.255.255.255
acl server src 192.168.1.251/255.255.255.255
acl umum src 192.168.1.0/255.255.255.0
acl staff src 192.168.1.1 192.168.1.111 192.168.1.2 192.168.1.4 192.168.1.71

delay_pools 3

delay_class 1 1
delay_parameters 1 -1/-1
delay_access 1 allow admin
delay_access 1 allow server
delay_access 1 deny all

delay_class  2 1
delay_parameters 2 1500/64000
delay_access 2 allow staf
delay_access 2 deny all

delay_class  3 1
delay_parameters 3 1000/32000
delay_access 3 allow umum
delay_access 3 deny all

Cara mencobanya paling mudah adalah dengan menggunakan donlot manajer semacam DAP, GetRight maka akan terlihat bandwidth sudah dibatasi.

Contoh 2

Delay pools juga dapat digunakan untuk membatasi donlot file untuk extensi tertentu.
Gunakan ACL url_regex untuk mengatasi hal ini.
Contoh dibawah digunakan untuk membatasi donlot file multimedia hingga 1 kByte/sec.

acl multimedia url_regex -i \.mp3$ \.rm$ \.mpg$ \.mpeg$ \.avi$ \.dat$
delay_pools 1
delay_class 1 1
delay_parameters 1 1000/16000
delay_access 1 allow multimedia
delay_access 1 deny ALL

Contoh 3 dari forum.linux.or.id

bagaimana caranya membuat delay pools untuk membatasi download di siang hari untuk 15 klient sedangkan malam harinya lost asumsi jamnya ( 10:00 – 21:00)

acl LTIME time SMTWHFA 10:00-21:00

acl download url_regex -i ftp \.exe$ \.mp3$ \.mp4$ \.tar.gz$ \.gz$ \.tar.bz2$ \.rpm$ \.zip$ \.rar$
acl download url_regex -i \.avi$ \.mpg$ \.mpeg$ \.rm$ \.iso$ \.wav$ \.mov$ \.dat$ \.mpe$ \.mid$
acl download url_regex -i \.midi$ \.rmi$ \.wma$ \.wmv$ \.ogg$ \.ogm$ \.m1v$ \.mp2$ \.mpa$ \.wax$
acl download url_regex -i \.m3u$ \.asx$ \.wpl$ \.wmx$ \.dvr-ms$ \.snd$ \.au$ \.aif$ \.asf$ \.m2v$
acl download url_regex -i \.m2p$ \.ts$ \.tp$ \.trp$ \.div$ \.divx$ \.mod$ \.vob$ \.aob$ \.dts$
acl download url_regex -i \.ac3$ \.cda$ \.vro$ \.deb$

delay_pools 1

delay_class 1 1
delay_parameters 1 3000/3000
delay_access 1 allow download TIME
delay_access 1 deny all

Contoh 4

Mulyo Wardoyo
Bagaimana caranya membuat delay pools untuk membatasi download di siang hari dengan speed … dan malam hari dengan speed …, abis si bozz malem-nya mau pakai buat dolot.
Jadi pengennya pas malam bw buat user makin kecil, bukan malah di loss

acl JAM_KANTOR time SMTWHFA 07:00-18:00 

delay_pools 2 delay_class 1 2
delay_parameters 1 24000/32000 -1/-1
delay_access 1 allow riset JAM_KANTOR
delay_access 1 deny all 

delay_class 1 2
delay_parameters 2 8000/8000 -1/-1
delay_access 2 allow riset !JAM_KANTOR
delay_access 2 deny all

Contoh 5

wangsit masterpop3 yang semedi dengan pecelpenyu.
Saya ada bandwidth besar, 1mbps.
Ingin membatasi yang donlot file besar di atas 5mbyte, di beri speed 32kbps.
Misal bila ada 3 user yang donlot, tiap-tiap user akan mendapat bw maximal 32kbps.

acl user src 192.168.1.0/24

delay_pools 1
delay_class 1 2
delay_parameters 1 40000/10000000 4000/5000000
delay_access 1 allow user download
delay_access 1 deny ALL

Contoh 6 limit youtube

duppeh, untuk memaksa caching terhadap youtube ( sesuai wiki.squid-cache.org )

acl youtube dstdomain -i .youtube.com
acl striming url_regex -i get_video\?video_id videodownload\?
cache allow youtube
cache allow striming

dan harap di ingat untuk posisi tsb di atas sebaiknya diletakkan sebelum hierarchy_stoplist
kemudian bisa di gabung ke delay_pool juga

delay_class 2 3
delay_access 2 allow warnet striming
delay_access 2 deny all
delay_parameters 2 -1/-1 -1/-1 3000/200000

hasilnya :

Connection: 0x7f1da510
   FD 149, read 555, wrote 6508975
   FD desc: http://ash-v97.ash.youtube.com/get_video?video_id=YXF72VCyt5M
   in: buf 0x7fe65000, offset 0, size 4096
   peer: 192.168.0.111:3317
   me: 127.0.0.1:3127
   nrequests: 1
   defer: n 0, until 0
uri http://ash-v97.ash.youtube.com/get_video?video_id=YXF72VCyt5M
log_type TCP_MISS
out.offset 6508872, out.size 6508975
req_sz 555
entry 0x7d24e240/599CDB16D8D8DCB1395E960CD807BD8B
old_entry 0x0/N/A
start 1193286572.113589 (2131.525289 seconds ago)
username -
delay_pool 2 <= terkena delay

untuk delay_pool saya tidak menggunakan domain youtube.com, karena ternyata untuk url streaming nya sebagian hanya menggunakan ip address biasa, sehingga menggunakan regex spt di atas saya rasa lebih efektif.
silakan di eksperimen sendiri untuk regex nya, bisa dg menganalisa access.log atau kalau yg gampang menggunakan sqstat spt yg pernah di post di thread sebelah.

Sumber

http://www.google.com
http://www.squid-cache.org

 

Copas /kalau membaca sumber aslinya: http://oktobrima.staff.uns.ac.id/?p=59

Next Page »